《暗黑3》繁体中文客户端无法自动升级至1.0.2版本的解决办法

新客网 XKER.COM 时间:2012-05-30 22:30:03来源:驱动之家  评论:

昨天下午六点半美服《暗黑破坏神3》开始进行维护,持续时间长达8个小时,之后客户端版本1.0.1.9558升级至了1.0.2,但相信很多朋友也都遇到了相同的问题——繁体中文客户端无法自动升级至1.0.2版本,自然也就无法登陆美服进行游戏了。

造成这个问题的原因在于繁体中文客户端的认证服务器出现了问题,只要更换一下服务器就可以了。具体操作方法如下:

《暗黑3》繁体中文客户端无法自动升级至1.0.2版本的解决办法_新客网

1、关闭《暗黑破坏神3》客户端,并用记事本编辑器打开“agent.db”

XP用户位于C:\Documents and Settings\All Users\Application Data\Battle.net\Agent\agent.db

Win7/vista用户位于C:\ProgramData\Battle.net\Agent\agent.db

一定要看清楚文件路径,ProgramData文件夹默认是隐藏的,需要先显示隐藏文件夹才行,另外也不要图懒省事而去修改《暗黑破坏神3》文件夹下的“agent.db”。

《暗黑3》繁体中文客户端无法自动升级至1.0.2版本的解决办法_新客网

《暗黑3》繁体中文客户端无法自动升级至1.0.2版本的解决办法_新客网

2、找到所有的“http://zhTW.patch.battle.net:1119/patch”并修改为http://enUS.patch.battle.net:1119/patch”,修改之后保存并退出。

《暗黑3》繁体中文客户端无法自动升级至1.0.2版本的解决办法_新客网

3、再次运行《暗黑破坏神3》客户端即可更新至1.0.2.9749。

需要注意的是客户端更新之后就无法登陆亚服或者欧服进行游戏了,除非亚服和欧服的版本进度赶上美服。在修改之前最好现行备份一下“agent.db”,防止意外情况发生。

文/驱动之家

本文来源:驱动之家

如果您喜欢本文请分享给您的好友,谢谢!如想浏览更多更好的游戏新闻内容,请登录:http://www.xker.com/edu/news/8/index.html

相关内容标签:游戏新闻
评论列表(网友评论仅供网友表达个人看法,并不表明本站同意其观点或证实其描述)